What are your system requirements?

This list contains the minimum requirements necessary for PBS TeacherLine courses. You may use higher versions of software or faster internet connections, if desired.

Internet access
Internet Explorer or Netscape, Firefox, or Safari
RealPlayer
*Windows Media Player
Flash Player
Adobe Acrobat Reader
*QuickTime
*Java 1.4.2.

*These plug-ins are needed for a limited number of courses.

Confirm that you have the necessary software and settings on your computer by selecting running the "Check Your Computer" tool on the TeacherLine Web site.

Please note that our courses are not compatible with the iPad.

Be sure you have the right software & settings

Contact Us

Still can't find the information you need?

Check the progress of your help request.



Loading...